JavaScript图表库Highcharts入门教程(一):系统要求

翻译|使用教程|编辑:吴园园|2019-10-14 16:10:33.910|阅读 29 次

概述:本文将为您介绍配置Highcharts的系统要求。

相关链接:

Highcharts是一款纯JavaScript编写的图表库,为你的Web网站、Web应用程序提供直观、交互式图表。当前支持折线、曲线、区域、区域曲线图、柱形图、条形图、饼图、散点图、角度测量图、区域排列图、区域曲线排列图、柱形排列图、极坐标图等几十种图表类型。

Highcharts现已更新至最新版本7.2.0,新版本添加了新的顶级选项-说明;几乎所有系列都增加了对多个色轴的支持;增加了高对比度光和高对比度 - 黑暗主题,与背景形成3:1对比度,并修复了一些之前存在的BUG,赶快下载试用吧~

点击下载Highcharts最新试用版

系统要求

Highcharts完全基于本机浏览器技术,不需要Flash或Java之类的客户端插件。此外,您不需要在服务器上安装任何东西。没有PHP或ASP.NET。Highcharts仅需要highcharts.js内核即可运行。

Highcharts和Highstock在所有现代浏览器(包括移动设备和版本6中的Internet Explorer)中均可使用。标准浏览器使用SVG进行图形渲染。在旧版Internet Explorer(IE8和更低版本)中,使用VML绘制图形。

Highcharts和Highstock可在任何支持HTML的服务器上运行。您甚至可以从文件系统本地运行Highcharts,因为所有渲染都在浏览器中本地完成。

浏览器兼容性

我们使用最新版本在许多浏览器上测试我们的软件。知道Internet Explorer用户有不升级的趋势,我们还系统地测试了该浏览器的旧版本。Highcharts在以下浏览器版本上运行:

iOS(Safari)3.0以上

浏览器

支持的版本

Firefox

2.0 +

Chrome

1.0 +

Safari

4.0 +

Opera

9.0 +

Edge

12.0 +

Internet Explorer

6.0-8.0 partial support using polyfills

Internet Explorer

9.0 +

Android Browser

2.0 + *)

*)Android浏览器2.x的支持有限,请参见下文。

支持IE 6-8

为了支持IE 6-8,需要一些polyfills。第一个文件“ oldie-polyfills.js”包含一些常见的数组函数。该文件扩展了数组和对象原型,如果您有其他polyfill库,或者更喜欢使用自己的库,则可以将其省略。第二个文件“ oldie.js”包含VML渲染器,因为旧的IE不支持SVG渲染。在Highcharts主文件之前,必须包含polyfill。附带条件注释,它看起来像这样:

<!--[if lt IE 9]>
<script src="https://code.highcharts.com/modules/oldie-polyfills.js"></script>
<![endif]-->  
<script src="https://code.highcharts.com/highcharts.js"></script>
<!--[if lt IE 9]>
<script src="https://code.highcharts.com/modules/oldie.js"></script>
<![endif]-->

渲染引擎和性能

不同的浏览器支持不同的呈现技术,现代的浏览器支持SVG,但旧版本的Internet Explorer不支持,这里我们使用VML绘制图形。下表介绍了我们在各种浏览器中使用的技术:

浏览器版本

渲染技术

渲染效果

Internet Explorer 9

SVG

优秀

Internet Explorer 8

VML

Internet Explorer 7

VML

Internet Explorer 6

VML

Firefox

SVG

优秀

Chrome

SVG

优秀

Safari

SVG

优秀

Opera

SVG

优秀

iOS Safari

SVG

Android 3+

SVG

Android 2.x

Canvas

ANDROID 2.X

Android 2.x没有内置的SVG支持,因此我们基于canvg库为此系统创建了一个单独的渲染器。此解决方案有一些限制:
  • 共享工具提示始终处于启用状态。

  • 在第一次渲染期间,将从code.highcharts.com下载canvg渲染器+ rgbcolor.js + canvg.js(连接到一个文件)。这可以使global.canvasToolsURL选项进行配置。

  • 图表和系列动画已关闭。

  • 未启用图例中的显示/隐藏系列。

  • 序列和点触摸事件未启用。

  • 未启用缩放。

  • 不支持直接使用Renderer API向图表添加形状。

=====================================================

想要购买Highcharts正版授权的朋友可以咨询慧都官方客服

更多精彩内容,敬请关注下方的微信公众号,及时获取产品最新资讯▼▼▼

开源图表库Highcharts入门教程(一):系统要求



标签:

本站文章除注明转载外,均为本站原创或翻译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动成果

文章转载自:Highcharts https://www.highcharts.com/docs/getting-started/system-requirements

登录 慧都网发表评论


暂无评论...

为你推荐

  • 推荐视频
  • 推荐活动
  • 推荐产品
  • 推荐文章
  • 慧都慧问
相关厂商
相关产品
Highcharts

纯JavaScript编写的开源图表库,为你的Web应用程序提供直观的、交互式图表

在线
客服
在线
QQ
电话
咨询
400-700-1020
购物车 反馈 返回
顶部
在线客服系统
live chat